Jump to content
Sign in to follow this  

Space Race Bug #2?

Recommended Posts

After an early turn in the game, my option for Space Race just disappeared.  Realignment, Event, Place Influence, and Coup were all available, but never Space Race throughout multiple turns.  I played as USSR and before the space race option disappeared for me, I had played "Defectors" as a headline card.  I didn't think it would allow me to do this, but it worked.  I wonder if this triggered a bug?  The game number I was playing was #1277878.  I tried to access Space Race on multiple turns, at various times during the turn, but it was never even given as an option.

Please fix!?

Thanks so much,


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...